Amazon S3 in some areas are currently down.
Incident Report for Localize

Update from AWS about their outage earlier today, September 14, 2017.

Outage period:

Image of Outage

Detailed log:

Image of details

During this period Localize may have been unaccessible. This meant our customers were not able to access their Localize projects. However, existing translations continued to render on our customer's applications (unless they were also directly affected by the AWS S3 outage.) We apologize for any impact this may have caused for our customers.

Posted about 1 month ago. Sep 14, 2017 - 14:33 PDT

Resolved
Amazon appears to have resolved their S3 issues, which means you can access your Localize projects without delay.
Posted about 1 month ago. Sep 14, 2017 - 13:09 PDT
Monitoring
Amazon S3 is reporting increased error rates. We're monitoring the status of Amazon S3. Localizejs.com is currently up and translations are rendering for our customers.
Posted about 1 month ago. Sep 14, 2017 - 13:07 PDT
Identified
Localizejs.com may not be available. Translations are still rendering for our customers.
Posted about 1 month ago. Sep 14, 2017 - 12:21 PDT