Investigating: The Localize website and application are currently down.
Incident Report for Localize
Resolved
Localize and our application is back up. The outage was isolated to our website; the deliverability of translations to Localize customers translating their websites or web applications using our service remained available.
Posted 7 months ago. May 11, 2017 - 12:40 PDT
Investigating
We are currently investigating this issue.
Posted 7 months ago. May 11, 2017 - 12:20 PDT