AWS is currently experiencing issues impacting Localize
Incident Report for Localize Corporation
Resolved
Following the stabilization of AWS service, all Localize services have been fully restored and are stable. Thanks for your patience.
Posted almost 2 years ago. Feb 28, 2017 - 15:52 PST
Monitoring
Services are starting to recover as a result of Amazon Web Services stabilizing: https://status.aws.amazon.com. Emails are being sent out as expected. We expect other services to recover quickly. We apologize for the interruption to service and will continue to monitor our systems to ensure services remain stable.
Posted almost 2 years ago. Feb 28, 2017 - 14:57 PST
Investigating
We apologize for any issues you may experience with Localize. We are currently investigating issues involving slow performance, machine translations, emails, changes in phrase states. Services remain degraded due to a provider issue with AWS.
Posted almost 2 years ago. Feb 28, 2017 - 12:39 PST