Intermittent Login Issues
Incident Report for Localize Corporation
Resolved
Resolved: Some accounts are being automatically logged out after a certain period of time.
Posted over 1 year ago. Apr 12, 2017 - 16:00 PDT
Investigating
Some accounts are being automatically logged out after a certain period of time.
Posted over 1 year ago. Apr 12, 2017 - 15:35 PDT