In-App Subscription issues
Incident Report for Localize Corporation
Postmortem

A subscription bug was introduced on Friday, March 23rd preventing any users on a free trial plan from enrolling in a paid subscription from within the Localize app. This issue also prevented any customers currently on a paid plan from upgrading or downgrading subscriptions from within the Localize app. This issue happened during a pricing and plan change deployment for future customers and occured due to an incomplete front end testing setup in place to ensure in-app plan enrollment actions worked as normal. The issue impacted users on a free trial trying to move to a paid subscription and current paid customers attempting to upgrade or downgrade their plan subscription.

Moving forward, we will be taking steps to mitigate the chances of such issues from occurring again. Additional QA processes will be enacted across code deploys; especially ones that directly impact end user interactions and additional integration tests will be implemented that ensure specific high traffic paths are tested on a hourly and code change basis.

Please do not hesitate to reach out to support@localizejs.com with any questions.

Posted 7 months ago. Apr 04, 2018 - 16:32 PDT

Resolved
The in-app subscription issue has been resolved and functionality is back to normal for all users. We will be providing a formal postmortem in the next 24 hours.

Please do not hesitate to reach out to support@localizejs.com with any questions.
Posted 7 months ago. Apr 03, 2018 - 16:05 PDT
Monitoring
In-app subscription change and plan enrollment link fixes have been deployed. We will be monitoring the issue over the next 24 hours and please don't hesitate to reach out to support@localizejs.com with any questions or feedback.
Posted 7 months ago. Apr 02, 2018 - 12:54 PDT
Identified
We are currently experiencing an issue preventing users from enrolling or up/downgrading subscriptions from within the Localize app when logged in. We have identified the issue and will provide an update here once the subscription issue is resolved.

In the meantime, please do not hesitate to email support@localizejs.com with any subscription questions or needs. We are happy to help with any plan enrollments, upgrades, downgrades, or cancellations as to not cause any delays.
Posted 7 months ago. Apr 01, 2018 - 09:31 PDT