Emailer System Down
Incident Report for Localize Corporation
Resolved
The backend email issue resulting in intermittent failed delivery of account notification emails has been resolved. All emails are now triggering without delay.

Please do not hesitate to reach out to support@localizejs.com with any questions.
Posted 7 months ago. Apr 03, 2018 - 16:04 PDT
Monitoring
The backend email system is now triggering account notification emails without delay. We will be monitoring the issue over the next 24 and please don't hesitate to reach out to support@localizejs.com with any questions or feedback.
Posted 7 months ago. Apr 02, 2018 - 12:49 PDT
Investigating
We are currently experiencing issues with our email system causing intermittent failed delivery of account notification emails. The issue is being addressed and we will provide an update here as soon as the email system is back to normal.

Please don't hesitate to reach out to support@localizejs.com in the meantime with any questions.
Posted 7 months ago. Apr 01, 2018 - 09:25 PDT